McAfee Firewall users are able to ban the IP address of the local computer


Environment

Affected Suites:
McAfee Total Protection
McAfee Internet Security
McAfee AntiVirus Plus
McAfee LiveSafe

Affected Products:
Firewall
Net Guard

Affected Operating Systems:
Microsoft Windows 8, 8.1
Microsoft Windows 7
Microsoft Windows Vista
Microsoft Windows XP

Summary

This article details issues that could occur when the local IP and/or local network range are added to firewall rules and set to blocked. If a block rule is created that includes the IP of the local device, access to any other device will be blocked.

The following errors might display: 

Microsoft Internet Explorer: This page can't be displayed

Mozilla Firefox: Server not found

Google Chrome: Web Page is not available

Windows Notification Center: Access Type: No Internet Access 


 

Problem

When you create a new entry in Connections, or install a new product, it is possible to add the IP address of the computer you are using as Blocked. Blocking access to the local IP address can cause network connectivity problems, preventing you from going online.

 

Cause

You have added the local IP address to the Blocked list, causing Net Guard or the Firewall to block the connection.

Solution

When you create entries in Connections, do not include the IP address of your computer, or your local subnet, in the Blocked lists.

Use the following steps to determine your IP address and verify that it is not on the banned IPs list:

Determine the IP address for your computer

  1. Click Start, Run, type cmd, and click OK

    NOTES:

    Windows Vista and 7 users must access the command prompt by selecting Search in the Start menu, typing cmd, and then double-clicking cmd in the search results window. 

    Windows 8 and 8.1 users must press the Windows key + X to open the Power Users menu, then select the Command Prompt shortcut. This requires a keyboard and mouse.
     
  2. In the command prompt window, type ipconfig and press ENTER.
  3. Locate Ethernet adapter Local Area Connection in the results.
  4. Locate the line that reads IP Address or IPv4 Address
  5. Write down the numbers exactly as shown.
     

Verify that your IP address is not on the banned IPs list

  1. Open your McAfee application. 
  2. Select Web and Email Protection.
  3. Click Firewall.
  4. Select My Network Connections (may also be labeled Connections or Network Connections, depending on your version).
  5. Scroll through the list of IP addresses and IP ranges. Verify the IP address and Network used by your computer are not listed with a security level equal to Blocked.
  6. If the computer's IP is in a blocked list you can change the Network Type or delete the rule.

    NOTE: Your IP address must belong to a valid network connection rule.

Previous Document ID

TS100255

Rate this document   
Did this article resolve your issue?
 
Please provide any comments related to this content.