ERROR: 'Invalid Operating System', 'Product not compatible with operating system', or 'Unsupported 16 bit application'


Environment

Affected Suites:
McAfee Security suites for Windows

Affected Operating Systems:
Microsoft Windows 8
Microsoft Windows 7
Microsoft Windows Vista
Microsoft Windows XP

 

Problem

After you update your Windows operating system and install or use your McAfee Security software, you may receive one of the following errors:

  • Invalid Operating System
  • Product not compatible with operating system
  • Unsupported 16 bit application
  • The program or feature "\??\C:\Users\Windows\regsvr32.exe" cannot start or run due to incompatibility with 64-bit versions of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available.


 

Cause

There are two identified sources for these errors:  
 

  • There is another program running in Compatibility Mode
    The computer is running a program in Compatibility Mode and this can interfere with the McAfee product that is installed. 

    After you have upgraded your computer to a newer operating system (Windows XP to Windows Vista or Windows Vista to Windows 7) the compatibility settings might not be set correctly for some files or programs. These changes might have occurred either during the update, or by user action.

    Some versions of Windows test programs installed on the computer during an upgrade and if necessary modify compatibility settings. Compatibility settings are available to allow an application that is not compatible with the current version of the operating system to run in a mode that simulates the version of the operating system with which it is compatible. For example, if a program was originally designed to run on Windows XP and is not natively compatible with Windows Vista, you can configure the Compatibility Mode settings to Windows XP. After you set the compatibility option, that program starts in Windows XP mode each time you run it.

    McAfee applications work with the operating system and supporting applications in the native mode of the operating system, and not in Compatibility Mode. If compatibility settings are enabled, they can interfere with the installation and or operation of your suite. If you have applications that run in Compatibility Mode, perform the steps in Solution 1.

     
  • The operating system was upgraded without reinstalling the McAfee product(s)
    The version of the McAfee products that are installed on your computer were designed for a different operating system. If you have recently updated your computer to a newer operating system  (Windows XP to Windows Vista or 7) the process did not validate the compatibility of all installed software. This rarely occurs when upgrading from Windows Vista to Windows 7, because application validation for these operating systems is much stronger and includes both warning messages and upgrade prevention when compatibility is suspect.

    McAfee recommends that you remove and reinstall your McAfee security suite before you update to another operating system. After you update your operating system, you can reinstall the security applications from your online account. Continue to Solution 2 for instructions to remove and reinstall your McAfee software.

Solution 1

Reset Compatibility Mode settings for all current programs. 

IMPORTANT: The following changes will affect the Compatibility Mode settings of all programs on your system.

CAUTION: This article contains information about opening or modifying the registry.

  • The following information is intended for System Administrators. Registry modifications are irreversible and could cause system failure if done incorrectly.
  • Before proceeding, McAfee strongly recommends backing up your registry and understanding the restore process. For more information, see: http://support.microsoft.com/kb/256986.
  • Do not run a .REG file that is not confirmed to be a genuine registry import file.
  1. Click the following link and save the file to your Windows desktop:

    http://download.mcafee.com/products/licensed/cust_support_patches/TS100483.bat
     
  2. Double-click TS100483.bat.
  3. Restart your computer. 


If your computer experiences unexpected behavior, use these steps to revert to your original compatibility settings.  

  1. Open the registry editor:

    • Windows XP
      1. Click Start and select Run.
      2. Type regedit and click OK.
         
    • Windows 7 or Windows Vista
      1. Click the Windows Orb and type REGEDIT into the search box.
      2. Right-click REGEDIT and select Run as Administrator.
      3. Click Continue.
         
  2. Navigate to the following key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers%Random Number%
    (where %Random Number% is any number) 
     
  3. Right-click the key and select Rename.
  4. Rename the key to Layers.

Solution 2

Use the McAfee Consumer Product Removal (MCPR) tool to uninstall your McAfee products before you upgrade your operating system. See article TS101331 for detailed instructions on how to use the MCPR tool.

Previous Document ID

106854

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